Cripzone SMF Themes Site

All Things Public => SMF 2.1 RC2 => 2.1 RC2 Themes => Topic started by: Skhilled on Jun 24, 19, 10:45:06 AM

Title: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 24, 19, 10:45:06 AM
Here's CleanWhite updated for SMF 2.1 RC2! This version has the old style categories. Within the next day or so, I'll post one with the updated category style.  O0

Next up will be Ambassador! Have fun!!!  8)

EDIT: Updated this zip. Was missing a custom thumbnail.png file.


Edit: fixed white text in admin area, under current theme settings.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Oldcrow on Jun 24, 19, 11:53:42 AM
Nice skin just uploaded it but I'd like to see a small change see image.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 24, 19, 12:02:54 PM
So, you want that border removed between the board icon and info sections? The old style has the borders with a small white space between them.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Oldcrow on Jun 24, 19, 02:05:24 PM
So, you want that border removed between the board icon and info sections? The old style has the borders with a small white space between them.

No not the border, The theme skin is excellent, I'd like to see the  image  I'd like black the same colour as the skin, not that blue colour.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 25, 19, 09:30:42 AM
I'm not sure what you've done but those are not the icons included with that theme. There is no blue in that theme. You can see that theme in the link below. I created a brand new test site and installed it on it before posting it to make sure it worked as it should. What is the SMF version you installed it on?

https://skhilled.com/rc2_updated/index.php

Btw, this version does include the added code for the posting icons which are shown at the bottom of the categories on the forum page.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Scrubmeister on Jun 25, 19, 05:00:27 PM
He created a new theme!  :)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Oldcrow on Jun 25, 19, 08:17:18 PM
He created a new theme!  :)

Probably did but I removed default1 and put cleanwhite in place, still came out with the blue
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 26, 19, 08:12:53 AM
So, are you saying that you edited or removed the default theme? If so, you should never do either one. It will cause you all kinds of problems. If you use a custom theme just change to the new theme. If you want a copy of the default them make a copy and edit that instead and give it a different name.

What is the SMF version you installed it on?

EDIT: Updated the zip. Was missing a custom thumbnail.png file so you can see the preview image in things like a theme block.  O0
Title: Re: CleanWhite 2.1 - Old Style
Post by: Oldcrow on Jun 26, 19, 12:01:26 PM
So, are you saying that you edited or removed the default theme? If so, you should never do either one. It will cause you all kinds of problems. If you use a custom theme just change to the new theme. If you want a copy of the default them make a copy and edit that instead and give it a different name.

What is the SMF version you installed it on?

EDIT: Updated the zip. Was missing a custom thumbnail.png file so you can see the preview image in things like a theme block.  O0
defult1
No I didn't remove the default skin.. When you install a new skin below it says something like default1, I just changed that to cleanwhite. It goes back to default after..
Title: Re: CleanWhite 2.1 - Old Style
Post by: Oldcrow on Jun 26, 19, 12:06:35 PM
Version Information:
 Forum version: SMF 2.1 RC2
 Current SMF version: SMF 2.1 RC2

Reinstalled again from the first post download, still got the blue icons..

Only one way to install the skin
Title: Re: CleanWhite 2.1 - Old Style
Post by: Oldcrow on Jun 26, 19, 12:16:59 PM
I installed it on my live forum, works good on there.
Title: Re: CleanWhite 2.1 - Old Style
Post by: trams on Jun 26, 19, 04:37:14 PM
Next up will be Ambassador! Have fun!!!  8)
Will it work even with SMF 2.0.15?
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 27, 19, 08:18:16 AM
I installed it on my live forum, works good on there.

Ron, open the zip and upload /images/boardicons.png to the same folder on your server to get the original icons. If you just want to make the one in your screenshot black then download that image from your server and make it black.

Will it work even with SMF 2.0.15?

No, these will only work with SMF 2.1 as it says in the first post. If you want this theme for 2.0.15 there is already a version in the downloads. I am just upgrading and making new versions of the themes we already have so they will work with 2.1.
Title: Re: CleanWhite 2.1 - Old Style
Post by: trams on Jun 27, 19, 08:36:48 AM
No, these will only work with SMF 2.1 as it says in the first post. If you want this theme for 2.0.15 there is already a version in the downloads. I am just upgrading and making new versions of the themes we already have so they will work with 2.1.
Sorry, my bad. I was looking for a responsive version of Ambassador for SMF 2.0.15 and I misunderstood your announcement. Ambassador for SMF 2.1 will be full responsive?
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 27, 19, 08:44:18 AM
Yes, all themes for 2.1 will be responsive, it is built into the SMF 2.1 code. ;)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Jun 28, 19, 07:41:36 PM
@Ron, did you get it working the way you want?
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Sep 22, 19, 10:58:44 AM
CleanWhite has been updated to include a fix. Please download from the first post or change the following code:

Index.css line 2562, change this:

Code: [Select]
#pick_theme .selected {
background: #cddbe6;
}

To this:

Code: [Select]
#pick_theme .selected {
background: #1f1f1f;
}
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 14, 20, 04:54:23 PM
Hello,

I am using SMF 2.1 RC2+ (last Github build).
The Cleanwhite theme is not compatible with this build, I use only index.css file (and some images) from your theme, fully replacing CSS file in default theme.

That is my test forum: https://bg-nacionalisti.org/test/index.php

I have two questions:

1. How to add your copyright info into the footer?
2. In message index, there is a white space in the subbar, is it possible to fix this?

Click => (https://i.postimg.cc/CZ9d9Zg9/Cleanwhite.jpg) (https://postimg.cc/CZ9d9Zg9)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 14, 20, 05:22:57 PM
Hi Hatshepsut and welcome to CZ! :)

1. What browser are you using because I can see the white space but it is not in the same place as the image you are showing. It is also not in the same place as the link you give to your site. All browsers I've tried do not show it in that place but do show a white space.

2.  Have you made any code changes to the theme?

3.  The RC versions of themes here are solely designed for the SMF.org version that is in their downloads and not for the Github versions. They update too often to keep up and there are 70+ themes here. So, we personally do not support the Github versions.

The copyright can be adjusted in index.template.php although it appears it was modified by someone because some of it is missing. Specifically, the "Modified by The BuildzHosting Team" part which is missing. If you remove the copyright then you'll have to fix it on your own.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 14, 20, 10:38:23 PM
My browser is Google Chrome, the white space is different, because I'm using moderation icons in the right.
Guests can see white space at the end of subbar:

Click => (https://i.postimg.cc/68YR3LsZ/Cleanwhite2.jpg) (https://postimg.cc/68YR3LsZ)

I don't made any code changes, I just have copied index.css file, and some of images (main_block.png, menu_gfx.png, menu_gfx2.png).
All the rest of files are from SMF default theme.


P.S. I have added your copyright info, you can check whether it's correct  :)

You can see the modified theme also onto my working forum, with background and board icons in addition:

https://bg-nacionalisti.org/BNF/index.php?action=forum

I have made some changes in its index.css file about the footer.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 15, 20, 09:04:36 AM
You will need to find:

#topic_header .lastpost {
    margin-right: 48px;
}

Change it to:

#topic_header .lastpost {
    margin-right: 0;
}
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 15, 20, 03:43:39 PM
I found why the white space appears in Message index subbar. One of installed mods - 'Avatars Display Integration' is changing the table structure. After uninstalling of this mod there is no more white space in the subbar  :)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 15, 20, 04:24:04 PM
Ah! Ok, I knew there had to be something that changed the code. Glad this is solved. :)
Title: Re: CleanWhite 2.1 - Old Style
Post by: lesmond on Mar 24, 20, 09:08:02 AM
Found a small color error in the admin area under Current theme settings.


In  /Themes/CleanWhite21/css/index.css

line 3780
Code: (find) [Select]
   color: #fff;

Code: (change to) [Select]
   color: #777;

(https://tinypix.top/images/2020/03/24/Bho7L.png)


Updated first post with new attachment.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 25, 20, 12:39:44 AM
Found a small color error in the admin area under Current theme settings.


In  /Themes/CleanWhite21/css/index.css

line 3780


The line number is 3780 in original CSS theme file, but if someone is made changes into index.css (like me), it will be more difficult to find this code  :)

Find:

Code: [Select]
h3.titlebg {
border-radius: 4px;
background-image: linear-gradient(to bottom, #757575 0%, #4d4d4d 70%);
color: #fff;
font-family: "Tahoma", sans-serif;
font-weight: bold;
overflow: hidden;
padding: 6px 12px 5px 12px;
text-shadow: none;

Replace color code from #fff to #777

P.S. But I recommend color code #ffa500 (Orange)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 25, 20, 03:07:38 AM
Thank you, Hatshepsut. :)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 30, 20, 01:20:54 AM
I found one issue with edit button drop menu:

Click => (https://i.ibb.co/gRvBzNs/Cleanwhite-issue.jpg) (https://ibb.co/gRvBzNs)

The command on the 4th line - 'Report to moderator' is wrapped and word 'moderator'  overlaps the command of the 5th line - 'Issue warning'

Maybe it's needed to increase menu height or width to fit all the commands.
I'm looking in index.css file, but cannot find the proper lines to edit  :-\
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 30, 20, 10:33:47 AM
I am not seeing that in my version with no mods. I see what's in the attachment below. Maybe a mod you have installed is causing this?
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 30, 20, 10:50:07 AM
Please keep in mind that these themes are only designed to work with the RC2 version in the SMF.org downloads. They may not work with github or nightly version because the code keeps changing.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 30, 20, 01:21:45 PM
Yes, in RC2 the link 'Report to moderator' is located into the post body, but in the next Github builds this link is moved to the drop menu as separate command.
I will wait for RC3 to see how it works :)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 31, 20, 08:45:59 AM
In the SMF version that dropdown is in ".quickbuttons li.post_options". I believe that is in at least two places, maybe more. So, I would do a search for that.
Title: Re: CleanWhite 2.1 - Old Style
Post by: Hatshepsut on Mar 31, 20, 10:06:31 AM
In the SMF version that dropdown is in ".quickbuttons li.post_options". I believe that is in at least two places, maybe more. So, I would do a search for that.

Problem solved :) I have changed command name 'Report to moderator' to 'Report this post', and now the command is no wrapped in the drop menu:

Click => (https://i.postimg.cc/s1q5YrBV/Cleanwhite-solved.jpg) (https://postimg.cc/s1q5YrBV)
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Mar 31, 20, 10:28:35 AM
Ah! Good thinking!  O0
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Oct 19, 20, 09:52:47 AM
@Hatshepsut, sorry but I did a complete restore and lost your last post as well as mine. Something is really wrong. I'm hoping the db is not corrupted. We'll see what we can do to fix things. I do have a backup of the themes on my HD so no worries there. Just gotta try and see if this can be fixed...
Title: Re: CleanWhite 2.1 - Old Style
Post by: Skhilled on Oct 23, 20, 09:33:53 AM
Not sure what happened but I've uploaded the theme to the first post again. :(

Hopefully, the db is not corrupted...