Cripzone SMF Themes Site

All Things Public => Theme Support => Topic started by: Sledge on Aug 06, 20, 07:54:05 PM

Title: Whitebox Logo
Post by: Sledge on Aug 06, 20, 07:54:05 PM
Link to my forum: http://www.thepoliticalcapital.com
SMF version: 2.0.17
TP version: 1.6.7
Default Forum Language: English
Theme name and version: WhiteBox by Crip
Browser Name and Version: Firefox
Mods installed: Tinyportal
Related Error messages: None

Hi.
I'm trying to change the logo but so far have had no success. If I use an image with any other height/width than the original .png, nothing shows. It is blank where the image is supposed to be. I attempted to tweak the css for the correct image size for what I want to use but still nothing. Below is the code in the theme for displaying the logo:

Quote
#logo a {
    position: absolute;
    top: 7.3em;
    left: 4em;
    display: block;
    width: 254px;
    height: 60px;
    cursor: pointer;
    background: url(../images/id/logo.png) no-repeat;

What I'm trying to do is use an image that is slightly taller but stretches almost the width of the header. Does anyone have any insight on how I can make this happen? Attached is the image size I'm wanting to use.

Thanks.
Title: Re: Whitebox Logo
Post by: Skhilled on Aug 07, 20, 09:24:24 AM
Hi Sledge and welcome to CZ! :)

I just put this on a test site as shown in the link below. Is this how you would like it to show? Please keep in mind that SMF 2.0.17 is not mobile ready so it may not look correct on mobile devices. On my PC, it looks good but on my tablet it stretches completely past the right side of the header.

https://skhilled.com/smf17/index.php

If this is what you wanted, as shown in the link, I've posted the code for it below. Remember, the code below shows the image in the same directory as the original logo... /images/id/:

Code: [Select]
#logo a {
position: absolute;
top: 7.3em;
left: 4em;
display: block;
width: 1200px;
height: 141px;
cursor: pointer;
background: url(../images/id/tpclogobase.gif) no-repeat;
}
Title: Re: Whitebox Logo
Post by: Sledge on Aug 07, 20, 11:13:15 AM
Huh. That's exactly what I did. Maybe I messed up the filename. Looks like it works.

Thanks for pointing out the problem with displaying on mobile.

 O0
Title: Re: Whitebox Logo
Post by: Skhilled on Aug 07, 20, 11:18:03 AM
No problem. SMF 2.1 works great with mobile but does have some bugs still... you can also edit mobile files to get the look you want but may take a LONG time for the actual release version. :(.